[erlang-questions] edoc broken in current master / R16A!

Nico Kruber <>
Mon Feb 4 17:34:32 CET 2013


On Wednesday 30 Jan 2013 15:35:41 you wrote:
> On Wednesday 30 Jan 2013 15:34:26 you wrote:
> > we regularly check that Scalaris builds on master and since the checks of
> > 11 Jan 2013 6am CET, creating the documentation with edoc fails.
> > We don't use packages, although we do put files into sub-folders - anyway,
> > I guess a function_clause should not be returned to the user at any point
> > (see below)
> > 
> > svn co http://scalaris.googlecode.com/svn/trunk/ scalaris
> > cd scalaris
> > make doc
> > ------------------------------
> > /home/buildbot/apps/erlang-dev/bin/erl -noshell -run edoc_run application
> > "'scalaris'" \
> > 
> > 	'"."' '[{def, {vsn, "0.5.0+svn"}}, no_packages, {preprocess, true},
> > 
> > {includes, ["include", "contrib/yaws/include",
> > "contrib/log4erl/include"]},
> > {sort_functions, false}, {pretty_printer, erl_pp}, {macros,
> > [{tid_not_builtin, true}, {with_export_type_support, true},
> > {have_cthooks_support, true}, {have_callback_support, true}]}]'
> > edoc: edoc terminated abnormally: {function_clause,
> > 
> >                                 [{edoc_lib,find_sources_3,
> >                                 
> >                                      [["random_bias.erl",[...]|...],
> >                                      
> >                                       "./src/rrepair",rrepair|...],
> >                                      
> >                                      [{file,...},{...}]},
> >                                  
> >                                  {edoc_lib,find_sources_2,5,[{...}|...]},
> >                                  {edoc_lib,'-find_sources_3/6-lc$^0/1-0-',
> >                                  5,
> > 
> > [...]},
> > 
> >                                  {edoc_lib,find_sources_2,5,...},
> >                                  {edoc_lib,find_sources_1,...},
> >                                  {edoc_lib,...},
> >                                  {...}|...]}.
> > 
> > make: *** [.make-doc] Error 1
> > ------------------------------
> 
> maybe this commit is related
> https://github.com/erlang/otp/commit/beb660aa59a8d9cd7f65b8b91dc5dd9bc74015e
> 0
> 
> Nico

I just tested with R16A and the problem is the same



More information about the erlang-questions mailing list