[erlang-questions] werl.exe home path issue, possible command line option bug

Patrik Nyblom <>
Mon Oct 29 18:16:43 CET 2012


On windows it's homedrive and homepath that's searched, so start Erlang 
with -env HOMEDRIVE C: -env HOMEPATH "\Users\bwilliams"

Cheers,
/Patrik
On 10/23/2012 03:07 AM, Brian W wrote:
> The windows domain I am on at work sets these two ENV variables very dumbly:
> HOMEDRIVE=U:
> HOMEPATH=\
>
> U isn't always mounted due to travel between locations.
>
> I set this one manually:
> HOME=C:\Users\bwilliams
>
> A default run of erl or werl gives me:
> =ERROR REPORT==== 22-Oct-2012::20:52:08 ===
> file:path_eval([".","U:\\"],".erlang"): I/O error
>
> Because the drive isn't mounted
>
> If i try
> werl -env HOME "C:\Users\bwilliams" I get the same error
>
> If I try
> werl -home "C:\Users\bwilliams" I do not get the error, but my .erlang
> does not get executed either
>
> If I run erl or werl from "C:\Users\bwilliams" directory on the
> command line it finds my .erlang and runs it with no problem
>
> I've managed to work around this by setting the "Start In" value in
> the windows shortcut properties, and start werl from my real home
> directory, but I think -home not actually loading my .erlang file is a
> bug.
>
>




More information about the erlang-questions mailing list