[erlang-questions] Rebar, common_test and cover issue

Maxim Treskin <>
Tue Mar 13 10:55:53 CET 2012


Yes, this modules loaded in tests. How I can fix this? Rename SUIT modules?

On 13 March 2012 16:38, Siri Hansen <> wrote:

> This would typically happen if your test loads my_module1 and my_module2.
> Could that be the case?
> /siri
>
> Den 10:30 13. mars 2012 skrev Maxim Treskin <> følgende:
>
>> Hello
>>
>> I have strange behaviour of rebar+common_test+cover.
>> There is two files in ./test/:
>>
>> my_module1_SUITE.erl
>> my_module2_SUITE.erl
>>
>> where ct suites defined. When I run `rebar ct verbose=1` I see:
>>
>> ```
>> ...
>> Cover compiling 'myapp' (16 files) - this may take some time... done
>> ...
>> Cover analysing...
>> WARNING: Analysis failed for my_module1. Reason:
>> {error,{not_cover_compiled,my_module1}}
>> WARNING: Analysis failed for my_module2. Reason:
>> {error,{not_cover_compiled,my_module2}}
>> ```
>>
>> Why I see no any error before at cover compilation step?
>>
>> Moreover, if I just replace my_module1_SUITE:all/0 to return just empty
>> list [], warning "Analysis failed for my_module1" disappears, and cover for
>> this file appears in cover.html log.
>>
>> Can you explain me this strange issues? Is this any bug or expected
>> behaviour?
>>
>> Thank you.
>>
>> --
>> Maxim Treskin
>> http://metachord.com
>>
>> _______________________________________________
>> erlang-questions mailing list
>> 
>> http://erlang.org/mailman/listinfo/erlang-questions
>>
>>
>


-- 
Maxim Treskin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20120313/b1444014/attachment.html>


More information about the erlang-questions mailing list