[erlang-questions] How can I debug this?

tom kelly <>
Sun Jul 22 17:16:06 CEST 2012


Hi Ian,

I'm CC'ing the list again. It was probably a typo not including them on
your mail? and I think it's important that more people see you points. If
we want Erlang usage to grow it's important that we address issues like
this as much as possible.

I'm happy to hear my input helped, and I find your comments as a newbie
interesting. I didn't see that thread your referenced last week (going to
search for it as soon as I hit send) but I'm sure we can all associate with
the frustrations of struggling with unfamiliar tools or environments. I can
only speak for myself but will try to smooth things for newbies, even if
it's only by replying to similar questions here more often.

//TTom


On Sat, Jul 21, 2012 at 10:16 PM, Ian <> wrote:

>  Hi Tom,
>
> Your right - it cannot find boss.beam.  There is no such file on my
> system.
>
> After some investigation on the Ubuntu system, I discover that it should
> be in D:\ChicagoBoss\bin with a lot of other .beam files.
>
> In fact the ChicargoBoss\bin directory has no .beam files at all. So I
> tried to compile them. That crashed.
>
> After some more investigation it appears that  the file
> D:\ChicagoBoss\deps\proper\include\compile_flags.hrl did not exist.
>
> What should it contain? Back to the Unbuntu system and found that it is
> empty! After "touching" it, the compile worked and I now have a running
> system under windows. Thank you for your help - it was just the information
> I needed.
>
> I wrote last week in another thread that I agreed with Dimitii in his talk
> in Stockholm that it was too difficult to do the easy stuff in Erlang. It
> has taken two days and help from kind people to get me over these initial
> teething problems.
>
> But note that I was doing real basic newbie stuff.  I downloaded the
> STANDARD install of erlang for my operating system, and the STANDARD
> install of Chicago Boss, installed them into the STANDARD locations, and
> attempted to set up a web server to serve "Hello World" following
> instructions included with those downloads.
>
> But look at what went wrong.
>   The install of Erlang did not set it up my path.
>   Chicago Boss assumed I had a suitable Make on my machine.
>   Chicago Boss failed to create a file that was necessary.
>   The error message was incomprehensible to a newbie.
>
> Trivial problems for the experienced Erlang buff, I'm sure, but for a
> newbie (or a manager who is authorising the investigation) they are
> stoppers.  These problems must be slowing the adoption of Erlang. That is a
> pity, because Erlang is very strongly positioned for major growth because
> it is "the way" to take advantage of multiple cores.  Actors, message
> passing, no shared state, no slouch, reliable and easy to scale to multiple
> cores/cpus - what's not to like?
> </rant>
>
> Thanks again Tom, your information was all I needed.
>
> Ian
>
>
> On 21/07/2012 14:51, tom kelly wrote:
>
> Hi,
> I've never worked with Chicago boss but it looks like your start script
> doesn't have the path to boss.beam.
>
> Your error message:
> {"init terminating in
> do_boot",{undef,[{boss,start,[],[],{init,start_it,1,[{file,"init.erl"},[line,1041}]},{init,start_em,1,[{file,"init.erl"},{line,1022}]}]}}
>
>
> says that during startup it tried to call "boss:start()." but that this is
> undefined, probably because it didn't have boss.beam in its path.
> You should locate boss.beam on your system and check that its location is
> added.
> HTH,
> //TTom.
>
>
> On Fri, Jul 20, 2012 at 3:05 PM, Ian <> wrote:
>
>> Hi All,
>>
>> I am attempting to work through the Chicago Boss quickstart tutorial at
>> https://github.com/evanmiller/ChicagoBoss/wiki/Quickstart
>>
>> I am using Windows 7 - 64 bit, and the R15B release of Erlang.  New to
>> Erlang.
>>
>> First a minor bug - I think I installed the 32 bit version, removed it,
>> and installed the 64 bit version.  Then I discovered that the 64 bit
>>  version's bin directory is C:\Program Files\erl5.9.1\bin but the directory
>> in the path was C:\Program Files (x86)\erl5.9.1\bin. That was why nothing
>> worked.
>>
>> After that was corrected, I created the project and set up the file in
>> Step 4, before starting the server with start-server.bat. The werl window
>> flashed up an error message for a second or so - and vanished before I
>> could read it!
>>
>> A few tries later I was able to catch it in a screen dump. The error
>> message was:
>>
>> {"init terminating in
>> do_boot",{undef,[{boss,start,[],[],{init,start_it,1,[{file
>> ,"init.erl"},[line,1041}]},{init,start_em,1,[{file,"init.erl"},{line,1022}]}]}}
>>
>>
>> (copied by hand)
>>
>> I know this means the server did not start up. But why, and what have I
>> done wrong/missed out? I have not found a init.erl file.
>>
>> My project is called erlian and is in d:\erlian . The file
>> D:\erlian\src\controller\erlian_greeting_controller.erl
>> contains:
>>
>> -module(erlian_greeting_controller, [Req]).
>> -compile(export_all).
>>
>> hello('GET', []) ->
>>     {output, "<strong>Erlian says hello!</strong>"}.
>>
>> (copy/pasted)
>>
>> Help much appreciated.
>>
>> Ian
>>
>>
>>
>> _______________________________________________
>> erlang-questions mailing list
>> 
>> http://erlang.org/mailman/listinfo/erlang-questions
>>
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20120722/90ff66fc/attachment.html>


More information about the erlang-questions mailing list