[erlang-questions] exmpp and rebar

CGS <>
Wed Nov 2 09:10:59 CET 2011


You need to include the path toward you exmpp or put exmpp into the 
Erlang lib standard path. It looks like your application doesn't know 
from where to take exmpp.

Cheers,
CGS



On 11/02/2011 08:54 AM, Max Bourinov wrote:
> Hi guys,
>
> I have rebar-ized project that uses exmpp library. exmpp library 
> installed in my system (sudo make install).
>
> Since there is no properly rebar-ized exmpp I try to run in in my 
> application code manually instead of starting it in processor.app:
>
> start(_StartType, _StartArgs) ->
> ok = application:start(exmpp),
> processor_sup:start_link().
>
> When I test my application (not release) everything work like a charm.
>
> But when I do:
>
> ./rebar compile
> ./rebar generate
>
> and then run released node I have the following exception:
>
> Erlang R14B04 (erts-5.8.5) [source] [smp:2:2] [rq:2] [async-threads:5] 
> [hipe] [kernel-poll:true]
>
>
> =INFO REPORT==== 2-Nov-2011::10:38:08 ===
>     application: processor
>     exited: {bad_return,
>                 {{processor_app,start,[normal,[]]},
>                  {'EXIT',
>                      {{badmatch,
>                           {error,{"no such file or 
> directory","exmpp.app"}}},
>                       [{processor_app,start,2},
>                        {application_master,start_it_old,4}]}}}}
>     type: permanent
> {"Kernel pid 
> terminated",application_controller,"{application_start_failure,processor,{bad_return,{{processor_app,start,[normal,[]]},{'EXIT',{{badmatch,{error,{[110,111,32,115,117,99,104,32,102,105,108,101,32,111,114,32,100,105,114,101,99,116,111,114,121],[101,120,109,112,112,46,97,112,112]}}},[{processor_app,start,2},{application_master,start_it_old,4}]}}}}}"}
>
> Crash dump was written to: erl_crash.dump
> Kernel pid terminated (application_controller) 
> ({application_start_failure,processor,{bad_return,{{processor_app,start,[normal,[]]},{'EXIT',{{badmatch,{error,{[110,111,32,115,117,99,104,32,102,105,1
>
> As I already said this approach doesn't work. Do you have any ideas 
> how to properly configure my app to use exmpp?
>
> Best regards,
> Max
>
>
> _______________________________________________
> erlang-questions mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-questions

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20111102/4d2a384d/attachment.html>


More information about the erlang-questions mailing list