[erlang-questions] Appmon, pman on MacOSX

Ivan Uemlianin <>
Mon May 9 19:26:18 CEST 2011


Thanks, I didn't know I could do that. I think I might have to do something with MacPorts itself too, as I probably installed it under MacOS 10.5.

I rue the day I ever touched MacPorts. Package management on the mac is so bad I'm definitely going back to Debian on my next machine.

Best wishes

Ivan

Sent from iPhone.

On 9 May 2011, at 18:02, Anthony Ramine <> wrote:

> This is a MacPorts problem, you should probably rebuild xorg-libX11 and all of its dependencies and dependents.
> 
> Le 9 mai 2011 à 18:01, Ivan Uemlianin a écrit :
> 
>> Dear All
>> 
>> I'm running erlang R13B01 on MacOSX.6.  I've just tried to launch appmon from the erlang shell and got this error (and no appmon):
>> 
>>   dyld: Library not loaded: /opt/local/lib/libX11.6.dylib
>>   Referenced from: /opt/local/bin/wish8.5
>>   Reason: no suitable image found.  Did find:
>>   /opt/local/lib/libX11.6.dylib: mach-o, but wrong architecture
>> 
>> I've done a quick google but found nothing, so I'm about to go deeper.
>> 
>> In the meantime, has anybody else come up against this and found out how to fix it?
>> 
>> With thanks and best wishes
>> 
>> Ivan
>> 
>> 
>> -- 
>> ============================================================
>> Ivan A. Uemlianin
>> Speech Technology Research and Development
>> 
>>                   
>>                    www.llaisdy.com
>>                        llaisdy.wordpress.com
>>                    www.linkedin.com/in/ivanuemlianin
>> 
>>   "Froh, froh! Wie seine Sonnen, seine Sonnen fliegen"
>>                    (Schiller, Beethoven)
>> ============================================================
>> _______________________________________________
>> erlang-questions mailing list
>> 
>> http://erlang.org/mailman/listinfo/erlang-questions
> 
> --
> Anthony Ramine
> Dev:Extend
> http://dev-extend.eu
> 
> 
> 
> 



More information about the erlang-questions mailing list