Problem compiling R14B01 on OpenBSD amd64

Martijn Rijkeboer <>
Tue Dec 14 18:36:56 CET 2010


Hello,

I'm having trouble compiling Erlang R14B01 on OpenBSD 4.8 AMD64. I'm using
the following configure:

./configure --prefix=/usr/local/stow/otp-R14B01 \
  --disable-jinterface \
  --disable-odbc \
  --enable-threads \
  --enable-kernel-poll \
  --disable-hipe \
  --disable-smp-support

When running gmake I'm getting the following error:

cd lib && \
  ERL_TOP=/home/compile.git/workdir/otp_src_R14B01
PATH=/home/compile.git/workdir/otp_src_R14B01/bootstrap/bin:${PATH} \
        gmake opt SECONDARY_BOOTSTRAP=true
gmake[1]: Entering directory `/home/compile.git/workdir/otp_src_R14B01/lib'
gmake[2]: Entering directory
`/home/compile.git/workdir/otp_src_R14B01/lib/hipe'
=== Entering application hipe
gmake[3]: Entering directory
`/home/compile.git/workdir/otp_src_R14B01/lib/hipe/misc'
erlc -W  +debug_info +warn_exported_vars +warn_missing_spec
+warn_untyped_record -o../ebin hipe_consttab.erl
gmake[3]: *** [../ebin/hipe_consttab.beam] Bad system call (core dumped)
gmake[3]: Leaving directory
`/home/compile.git/workdir/otp_src_R14B01/lib/hipe/misc'
gmake[2]: *** [opt] Error 2
gmake[2]: Leaving directory
`/home/compile.git/workdir/otp_src_R14B01/lib/hipe'
gmake[1]: *** [opt] Error 2
gmake[1]: Leaving directory `/home/compile.git/workdir/otp_src_R14B01/lib'
gmake: *** [secondary_bootstrap_build] Error 2

Any ideas on what I'm doing wrong?

Kind regards,


Martijn Rijkeboer



More information about the erlang-questions mailing list