R13B03 linkedin driver incompatible with R13B01

Thijs <>
Fri Nov 27 08:50:28 CET 2009


Today I tried to use a linkedin driver that was compiled on a Linux
system with R13B03 on another machine that is still running R13B01.
Unfortunately I got this error:

driver_incorrect_version : "Driver compiled with incorrect version of
erl_driver.h"

I have no problems running R13B01 drivers on R13B03. I saw in the
release notes (OTP-8205) that erl_driver.h has been updated, but I
didn't expect this would be incompatible. Might be good to point this
out explicitly.


More information about the erlang-questions mailing list