[erlang-questions] where to find correct documentation for erlang distribution over SSL?

Michael McDaniel <>
Tue Mar 24 06:01:34 CET 2009


 Hey, Kris - a couple things ...


 *  /home/.erlang.cookie is same on both nodes ?
    or from erl shell, 
    1> erlang:set_cookie(node(), some_secret_cookie).
    2> erlang:get_cookie().
    'some_secret_cookie'
    3> 


 * do they 'pong' without SSL ?   


 * probably you already checked your firewall ports


On Mon, Mar 23, 2009 at 10:29:53PM -0500, Kris Prieb wrote:
> Michael, I'm already familiar with the contents at the link you
> mentioned through a lot of googling, but thanks anyway.
> 
> After some further noodling around I've been able to establish an SSL
> connection to a single node where I've created the initiating
> (non-erlang node) end point myself using the SSL application.  I still
> am unable get the full erlang distribution running on SSL, however, so
> I remain open to suggestions.
> 
> Kris
> 
> -------------------------------------------------------------------------------------------------------------
> Date: Mon, 23 Mar 2009 16:01:58 -0700
> From: Michael McDaniel <>
> Subject: Re: [erlang-questions] where to find correct documentation
>        for     erlang distribution over SSL?
> To: 
> Message-ID: <>
> Content-Type: text/plain; charset=iso-8859-1
> 
> 
>  old, but possibly will assist ...
> 
> 
>  http://trapexit.org/Distributed_erlang_using_ssl_through_firewalls
> 
> 
> ~M
> 
> 
> On Mon, Mar 23, 2009 at 04:35:51PM -0500, Kris Prieb wrote:
> > I have been trying to start erlang distribution over SSL using SSL
> > 3.10 in OTP R12-B5 by following Section 5 of the SSL User's Guide
> > (http://www.erlang.org/doc/apps/ssl/usersguide_frame.html). ?I have
> > gotten two nodes up, but I cannot get them to successfully
> > net_adm:ping/1 each other.?(I get a pang not a pong).  I only just
> > read that the documentation for distribution over SSL is in fact not
> > entirely correct.  As noted in the release notes for SSL 3.10:
> >
> > "1.1.3 Known Bugs and Problems
> > Running erlang distribution over ssl don't work as described in the
> > documentation.
> > Own Id: OTP-7536"
> >
> > Does anyone know where I might find correct documentation on erlang
> > distribution over SSL, or alternatively, what parts of the current
> > documentation are incorrect and how?
> >
> > Thanks in advance!
> > Kris
> > _______________________________________________
> > erlang-questions mailing list
> > 
> > http://www.erlang.org/mailman/listinfo/erlang-questions
> 
> --
> Michael McDaniel
> Portland, Oregon, USA
> http://autosys.us
> http://mmcdaniel.com/erlview
> _______________________________________________
> erlang-questions mailing list
> 
> http://www.erlang.org/mailman/listinfo/erlang-questions



More information about the erlang-questions mailing list