Strange behavior of PG2

shehan <>
Fri Jun 5 07:31:31 CEST 2009


Hi all,

I used PG2 in two different applications & both are visible to each other.
(i.e. same cookie used)  One application is ejabber related one. Other one
is related to SMPP client thing.  When member of PG2 deleted in ejabber
related one, seems it is applied to SMPP client application. In that erlang
logs, below error things can be seen. I don't know why this is happened.
Then SMPP client application became malfunctioning. I am using Erlang 11B-5
version. Pls help to solve this problem.

 

 

=ERROR REPORT==== 4-Jun-2009::14:49:03 ===

** Generic server pg2 terminating 

** Last message in was {'$gen_cast',

                           {del_member,

                               {ejabberd_node_groups,backend},

                               <13008.674.0>}}

** When Server state == {state,[<0.6868.739>,

                                <0.6868.739>,

                                <0.214.0>,

                                <0.214.0>,

                                <0.204.0>,

                                <0.204.0>,

                                <0.186.0>,

                                <0.186.0>,

                                <0.182.0>,

                                <0.182.0>,

                                <0.174.0>,

                                <0.174.0>,

                                <0.161.0>,

                                <0.158.0>,

                                <0.157.0>,

                                <0.156.0>]}

** Reason for termination == 

** {{badmatch,[]},

    [{pg2,del_member,3},

     {pg2,handle_cast,2},

     {gen_server,handle_msg,6},

     {proc_lib,init_p,5}]}

 

Br,

Shehan



More information about the erlang-questions mailing list