[erlang-questions] install_release/1 always returns enoent error

Kaiduan Xie <>
Sat Jan 10 01:36:13 CET 2009


Please follow the System Principles closely and use the source code
target_system.erl it provides. I had used the way to do hot update and it
worked well.

On Fri, Jan 9, 2009 at 5:44 PM, Sergey S <> wrote:

> Hello.
>
> On Fri, Jan 9, 2009 at 1:39 PM, Kaiduan Xie <> wrote:
>
>> I think you have to do install_release() from the erlang shell which
>> starts release A.
>
>
> I've already tried that. It leads to the same error.
>
> Please also read System Principles documentation
>> http://www.erlang.org/doc/pdf/system_principles.pdf  on how to start the
>> first target system.
>
>
> I've read that. I'm using initial Erlang system created by my packet
> manager as a target system. I start erlang by the following command:
>
> sudo erl -boot /usr/lib/erlang/releases/A/start
>
> I also tried adding "-mode embedded". (I'm using sudo so that Erlang can
> correctly do unpack_release/1)
>
> --
> Sergey
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20090109/404e255d/attachment.html>


More information about the erlang-questions mailing list