[erlang-questions] install_release/1 always returns enoent error

Sergey S <>
Fri Jan 9 23:44:28 CET 2009


Hello.

On Fri, Jan 9, 2009 at 1:39 PM, Kaiduan Xie <> wrote:

> I think you have to do install_release() from the erlang shell which starts
> release A.


I've already tried that. It leads to the same error.

Please also read System Principles documentation
> http://www.erlang.org/doc/pdf/system_principles.pdf  on how to start the
> first target system.


I've read that. I'm using initial Erlang system created by my packet manager
as a target system. I start erlang by the following command:

sudo erl -boot /usr/lib/erlang/releases/A/start

I also tried adding "-mode embedded". (I'm using sudo so that Erlang can
correctly do unpack_release/1)

--
Sergey
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20090109/54572d12/attachment.html>


More information about the erlang-questions mailing list