[erlang-questions] install_release/1 always returns enoent error

Sergey S <>
Fri Jan 9 20:14:54 CET 2009


Hello.

While reading OTP Design Principles (Release Handling part) I've found that
function release_handler:install_release/1 doesn't work as expected. It
returns a strange error, complaining about relup file:

Eshell V5.6.5  (abort with ^G)
1> release_handler:install_release("B").
{error,{enoent,"/usr/lib/erlang/releases/R12B/relup"}}

And it's true - there is no such a file. Instead of $ROOT/releases/R12B my
relup file resides in $ROOT/releases/B. I have no idea why release_handler
searches for relup in R12B dir :/ It looks like a bug...

I tried to copy my relup to R12B dir by hand, but It didn't help:

2> release_handler:install_release("B").
{error,{bad_relup_file,"/usr/lib/erlang/releases/R12B/relup"}}

Then, I've tried to find out the solution through Google. But what I've
found (please, look at the comments for this article) was:
http://spawnlink.com/articles/performing-real-time-upgrades-to-an-otp-system/

There are people who run into the same problem. Unfortunatelly nobody gave
solution to this problem.

Here is the sources of my test app (1.4Kb):
http://rapidshare.com/files/181485268/foo_app.tar.gz.html

Thanks!

--
Sergey
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20090109/d566a8b3/attachment.html>


More information about the erlang-questions mailing list