[erlang-questions] Using Dialyzer on Ubuntu 9.10?

Lovei Laszlo <>
Sat Dec 19 12:29:40 CET 2009


Kostis Sagonas írta:
> Lovei Laszlo wrote:
>>
>> Why does Dialyzer not support building plt from source code?
> 
> It does. 

That's great, how can I do that? "dialyzer --src --build_plt" says "Byte 
code compiled with debug_info is needed to build the PLT" (at least 
versions 1.9.2 and 2.1.0).

> But I doubt that the Ubuntu erlang package includes the source 
> code for libs.

Well, it doesn't, but at least there is a separate erlang-src package 
which contains all the sources. (So much for preserving disk 
space/bandwidth by excluding debug_info...)


Laszlo



More information about the erlang-questions mailing list