[erlang-questions] emacs erlang shell issue

Bill Clementson <>
Mon Jul 23 21:17:38 CEST 2007


jla415 <> writes:

> Kirill Zaborski wrote:
>> 
>> In emacs erlang shell I can not enter M or C (capital letters), when I try
>> press them they work like emacs META and CONTROL keys.
>> Is this a normal behavior or it has something to do with my emacs setup?
>> BTW I run emacs 22 on Windows XP
>> 
>> Best regards,
>> Kirill.
>> 
>
> last time someone asked about this problem on irc it was a result of some
> distel documentation somewhere saying to put something similar to this in
> your .emacs:

The following code snippet is from a blog posting I wrote, not the
distel documentation. The full blog post is here:
http://bc.tech.coop/blog/070528.html

> ;; A number of the erlang-extended-mode key bindings are useful in the shell
> too
> (defconst distel-shell-keys
>   '(("C-M-i"   erl-complete)
>     ("M-?"      erl-complete)
>     ("M-."      erl-find-source-under-point)
>     ("M-,"      erl-find-source-unwind) 
>     ("M-*"      erl-find-source-unwind) 
>     )
>   "Additional keys to bind when in Erlang shell.")
>
> (add-hook 'erlang-shell-mode-hook
> 	  (lambda ()
> 	    ;; add some Distel bindings to the Erlang shell
> 	    (dolist (spec distel-shell-keys)
> 	      (define-key erlang-shell-mode-map (car spec) (cadr spec)))))
>
>
> if you recently tried to install distel try commenting out this section and
> seeing if it helps...

The above code snippet adds some additional key bindings to
erlang-shell-mode. There should actually be a backslash if front of
each of the meta and control key definitions in this code
snippet. Unfortunately, I forgot to escape the backslashes in the HTML
code, so they didn't show up in my blog post. I've corrected this now
on the blog page.

My apologies for any confusion/hassles this might have caused.

--
Bill Clementson




More information about the erlang-questions mailing list