[erlang-questions] emacs erlang shell issue

jla415 <>
Mon Jul 23 06:29:51 CEST 2007




Kirill Zaborski wrote:
> 
> In emacs erlang shell I can not enter M or C (capital letters), when I try
> press them they work like emacs META and CONTROL keys.
> Is this a normal behavior or it has something to do with my emacs setup?
> BTW I run emacs 22 on Windows XP
> 
> Best regards,
> Kirill.
> 

last time someone asked about this problem on irc it was a result of some
distel documentation somewhere saying to put something similar to this in
your .emacs:

;; A number of the erlang-extended-mode key bindings are useful in the shell
too
(defconst distel-shell-keys
  '(("C-M-i"   erl-complete)
    ("M-?"      erl-complete)
    ("M-."      erl-find-source-under-point)
    ("M-,"      erl-find-source-unwind) 
    ("M-*"      erl-find-source-unwind) 
    )
  "Additional keys to bind when in Erlang shell.")

(add-hook 'erlang-shell-mode-hook
	  (lambda ()
	    ;; add some Distel bindings to the Erlang shell
	    (dolist (spec distel-shell-keys)
	      (define-key erlang-shell-mode-map (car spec) (cadr spec)))))


if you recently tried to install distel try commenting out this section and
seeing if it helps...
-- 
View this message in context: http://www.nabble.com/emacs-erlang-shell-issue-tf4126175.html#a11737737
Sent from the Erlang Questions mailing list archive at Nabble.com.




More information about the erlang-questions mailing list