[erlang-questions] Compiling Erlang in Kubuntu 6.0.6

Kirill Zaborski <>
Thu Nov 23 00:27:41 CET 2006


On 11/23/06, Mikael Pettersson <> wrote:
>
> Kirill Zaborski writes:
> > I'm a Linux newbie (at last I have installed it :) ) and now I'm trying
> to
> > install Erlang on my Kubunttu. There were some problems with packages
> but
> > I've solved them. Right now I can not  run make, it says:
> > hipe/hipe_mkliterals.c:351: error: 'X86_LEAF_WORDS' undeclared here (not
> in
> > a function)
> > hipe/hipe_mkliterals.c:352: error: 'X86_NR_ARG_REGS' undeclared here
> (not in
> > a function)
> > There is just 1 link in Google about this issue and it says that I need
> to
> > disable HiPE with ./configure --disable-hipe. I've tried this but I get
> the
> > same error.
> > I'm stuck :(
> > Maybe I miss something else?
>
> Post a build log from a freshly unpacked OTP R11B-2 tar ball,
> complete with the initial ./configure command and the subsequent
> make command.
>
> The errors could be caused by 'm4' failures earlier in the build.


Yep there was an error about m4, but I've installed it  (as some other
packages). It looks like there were some wrong intermediate result resulting
in this error. But I didn't find a way to clean up directory after erroneous
./configure.
But now I've run 'sudo apt-get build-dep erlang' and and started
installation from the beginning. Looks like it started to compile, it's too
late in Moscow - need some sleep. And sorry about not very Erlang-specific
issues :)

Thanks,
Kirill.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20061123/7db17ba8/attachment.html>


More information about the erlang-questions mailing list