[erlang-questions] Erlang doesn't like ubuntu 6.10

Cameron Kerr <>
Thu Nov 9 03:03:20 CET 2006


It's not something as simple as needing to do a 'sudo ldconfig' is it?

On 6/11/2006, at 1:04 PM, Tobias Löfgren wrote:

>
> Just a heads up for anyone else who uses Ubuntu. Erlang seems to  
> have trouble loading external libraries/driver on a Ubuntu 6.10  
> "Egdy Eft" system.
>
> I've just spent the better part of the weekend trying to figure out  
> what was going wrong. First it seemed like a problem with Yaws,  
> because erlang compiled fine and "worked". But yaws stopped with a  
> "exec 1: setuid_drv.so :not found".
>
> After much reinstalling and experimenting with different versions I  
> discovered that it was all dynamic loading of libraries that  
> failed. For example "crypto:start()." in the erl shell crashed in a  
> similar fashion.
>
> Maybe there is a simple solution to the problem, but at the moment  
> it eludes me, so I've downgraded. The same packages and erlang- 
> versions work perfectly fine in Ubuntu 6.06, so if you're using  
> Ubuntu and Erlang, don't upgrade ubuntu yet.
>
>
> /tobias
>
>
>
> _______________________________________________
> erlang-questions mailing list
> 
> http://www.erlang.org/mailman/listinfo/erlang-questions

-- 
• Cameron Kerr  • ✉  •
 •
• Telecommunications Teaching Fellow & SysAdmin •
• ✎ http://humbledown.org/blog/ • ✆ 021 02 333 294 •



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20061109/bb156227/attachment.html>


More information about the erlang-questions mailing list