R11B installation problem on debian

Mikael Pettersson <>
Mon Aug 7 14:26:42 CEST 2006


On Mon, 7 Aug 2006 08:48:49 -0300, Roberto Saccon wrote:
> I inspected the logfile for strange things and there were a
> lot of strange things and then I realized that on my XEN setup, I had
> only reserved 64 MB of RAM for that domain.
> 
> After increasing that, it did still not work, then I tried with
> "./configure --disable-hipe" and finally it worked, but of course I
> don't want to disable hipe.
> 
> Is there any known issue with debian sarge ? Any special library required ?

If both HiPE/x86 (or amd64) and threads are enabled, then you need either
an NPTL glibc, or a LinuxThreads glibc that has been configured for a
2.3.99 or later kernel. Otherwise LinuxThreads can't use "floating stacks"
and then it falls back to using %esp in ways that are fundamentally
incompatible with HiPE/x86. The only solution if you have a misconfigured
glibc is to disable either hipe or threads.



More information about the erlang-questions mailing list