R11B installation problem on debian

Roberto Saccon <>
Mon Aug 7 13:48:49 CEST 2006


I inspected the logfile for strange things and there were a
lot of strange things and then I realized that on my XEN setup, I had
only reserved 64 MB of RAM for that domain.

After increasing that, it did still not work, then I tried with
"./configure --disable-hipe" and finally it worked, but of course I
don't want to disable hipe.

Is there any known issue with debian sarge ? Any special library required ?

On 8/6/06, Mikael Pettersson <> wrote:
> On Sat, 5 Aug 2006 16:41:56 -0300, Roberto Saccon wrote:
> >I have previously successfully installed Erlang  R11B on my Ubuntu
> >machine, now I tried on a debian sarge server and after some minutes
> >of compiling, I got an error.
> ...
> >erlc -W   -I/usr/local/erlang/otp_src_R11B-0/lib/kernel/ebin
> >-I/usr/local/erlang/otp_src_R11B-0/lib/stdlib/ebin
> >-I/usr/local/erlang/otp_src_R11B-0/lib/sasl/ebin -o
> >/usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_clean.script
> >/usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_clean.rel )
> >stdlib: File not found: "stdlib.app"
> >
> >make[2]: *** [/usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_clean.script]
> >Error 1
> >make[2]: Leaving directory
> >`/usr/local/erlang/otp_src_R11B-0/erts/start_scripts'make[1]: ***
> >[local_setup] Error 2
> >make[1]: Leaving directory `/usr/local/erlang/otp_src_R11B-0/erts'
> >make: *** [local_setup] Error 2
> >debian:/usr/local/erlang/otp_src_R11B-0#
>
> I suspect that a previous error left lib/stdlib/ incomplete
> and without a stdlib.app. You should check the make log for
> earlier errors as well.
>


-- 
Roberto Saccon



More information about the erlang-questions mailing list