mnesia + disc_only_copies

klacke <>
Sat Feb 5 23:07:11 CET 2005


Hi all,

I'm having some problems with mnesia and disc_only_copies tables.
The error is pretty easy to recreate and I get the same error in
both R9C-0 and latest R10

I create a table, with disc_only_copies on two nodes
as in:


c() ->
    mnesia:create_table(a, 
                        [{attributes, record_info(fields,a)},
                         {disc_only_copies, [, ]}]).



I then populate the table with a fairly large amount of items,
say 500.000 records.

as:


populate(0) ->
    ok;
populate(I) ->
    mnesia:dirty_write(#a{key = I}),
    populate(I-1).



the record "a", doesn't matter it can be any record.

Anyway, when table is populated and I start/stop the
different nodes, the table needs to be copied from
one node to the other.
I get:

=ERROR REPORT==== 5-Feb-2005::23:23:09 ===
Got invalid data on distribution channel, offending packet is: 
<<112,131,104,3,97,2,67,5,103,67,245,0,0,0,101,0,0,0,0,3,131,104,2,103,67,71,0,0,0,122,0,0,0,0,1,104,2,67,183,108,0,0,0,8,104,3,97,13,98,0,2,34,88,109,0,0,16,0,0,0,9,144,18,52,86,120,0,0,2,98,131,104,6,100,0,1,97, .........


This is all done by dets:bchunk(), I've tried to find the error,
but to no avail.

Has anyone else had these problems, ??? Is _anybody_ using mnesia
with large disc_only_copies tables ???

The bug appears to be fairly easy to reproduce, but ...well 
hard to debug. Before digging deep into the bug, I thought I should
ask if anyone else has seen this ???


/klacke


-- 
Claes Wikstrom                        -- Caps lock is nowhere and
http://www.hyber.org                  -- everything is under control          



More information about the erlang-questions mailing list