unknown_catch_try_state under R10B-2

Mark Scandariato <>
Tue Dec 28 18:59:48 CET 2004

Same error with R10B-2 on Solaris.

Note that beam_validator appears to be new in R10B-2.


Vlad Dumitrescu wrote:
> Hi,
> I get the same error (with the same configuration), yet I don't understand why
> this error is platform-dependent...
> The error is inside internally generaed code for checking that State is a state
> record. You can compile with an 'E' as argument to see that internal code, and
> with an 'S' to see the beam assembly code. Might be interesting.
> The reported line is the second State#state{foo=bar}, but the funny thing is
> that commenting out _any_ of the two such lines makes the error message
> disappear...
> I'm afraid I'm not being very helpful, but the compiler is still somewhat of a
> black art for me :-) A better error message (when debugging in beam_validator is
> enabled:
>     c:/cygwin/home/vlad/foomod.erl:none: internal error in beam_validator;
>     crash reason: {{case_clause,{'EXIT',unknown_catch_try_state}},
>                    [{compile,'-select_passes/2-anonymous-2-',2},
>                     {compile,'-internal_comp/4-anonymous-1-',2},
>                     {compile,fold_comp,3},
>                     {compile,internal_comp,4},
>                     {compile,internal,3}]}
> About the use of a capital letter in the reported file name, my guess is that
> the Windows file name is capitalized: make:all() shows the real file name. If
> compiling with c(), a lower-case only name is showed.
> regards,
> Vlad

More information about the erlang-questions mailing list