Minor compatibility patches for R9B-0?

Kent Boortz <>
Wed Oct 9 08:59:38 CEST 2002


On Wednesday next week we will release the commercial distribution of
OTP R9B and short after that the OpenSource distribution R9B-0. Only
very small changes are allowed in this stage of the release process
but if you have any minor changes to the make files or configure
script that are needed to build on your system please let us know. I
can't promise the changes will make it into R9B-0, they may have to
wait for R9B-1.

We know about the RedHat 8.0 issues but this require bigger changes
than we have time to code and verify at this stage. 

HiPE support is now by default enabled by configure on platforms where
HiPE is supported. We know that HiPE support will not compile on
RedHat 5 and this will probably not be corrected. You need to set
--disable-hipe to compile on RedHat 5.

The pre-release snapshots can be found at

  http://www.erlang.org/download/snapshots/

Note that the 64 bit support is only tested on Solaris 8 UltraSparc
using gcc 3.1.1. 64 bit support is enabled by having a gcc that has 64
bit as the default compilation mode in the PATH.

Note that Tcl/Tk is not distributed with the sources any longer. GS
now uses the "wish" program installed on your system, i.e. for the GS
and the graphical tools to work you need to install Tcl/Tk 8.3 or 8.4,

README, hightlights.html etc are not updated. To find out what flags
are supported do

  % cd erts
  % autoconf
  % ./configure --help

kent



More information about the erlang-questions mailing list