mysterious GS 1.4.0 problems

Chris Pressey <>
Tue Mar 26 01:23:07 CET 2002


Follow-up on this: the version of GS is apparently not the problem.  I am
having the same problems now with the older version of GS.  The problem is
with the backend (gs-1.4.0/priv/tcl/bin/tclsh76.exe and
gs-1.4.0/priv/tcl/bin/wish42.exe).

The exact same version of Erlang and the exact same version of the GS
backend is installed on two computers running the exact same version of
Windows NT.  However on one computer, all calls to

  gs:read(ListBox, items)

fail due to the backend returning an integer which is way out of range for
what the (Erlang) backend wants (it wants 0-4 or so, the port program
returns numbers like 48 or 56 for no fathomable reason.)

It might be a problem with DLL's used by tclsh76.exe and wish42.exe.  If I
have time to dig into this further I'll post my findings here.

In the meantime I've worked around it by replacing calls to
gs:read(ListBox, items) with calls to an iterative function like

read_items(ListBox) ->
  read_items(ListBox, gs:read(ListBox, size)).
read_items(ListBox, 0) ->
  [];
read_items(ListBox, I) ->
  [gs:read(ListBox, {get, I}) | read_items(ListBox, I-1)].

This is of course much less efficient, but at least it works.

Chris

On Tue, 12 Mar 2002 16:30:19 -0600
"Chris Pressey" <> wrote:

> Hi all.
> 
> I have encountered a problem using R8 and GS 1.4.0.  Strangely, it only
> shows up on one of the three nodes R8 is installed on here (it's running
> WinNT, but so is one of the other nodes.)  Upon doing a simple gs:config
> on a listbox, I get an error like so:
> 
> =ERROR REPORT==== 12-Mar-2002::15:34:49 ===
> Error in process <0.112.0> on node '' with exit value:
> {{case_clause,48},[{gstk_port_handler,input_during_call,2},
> {gstk_port_handler,handle_input,3},{gstk_port_handler,wait_reply,2}]}
> gs error: user backend died reason
> {{case_clause,48},[{gstk_port_handler,input_during_call,2},
> {gstk_port_handler,handle_input,3},{gstk_port_handler,wait_reply,2}]}
> 
> I have worked around this error by grabbing GS 1.3.8 from R7B2 and using
> it instead.  It seems to work fine (in haste I just renamed the gs-1.3.8
> directory to gs-1.4.0, it would probably be more prudent to actually
> change the registry entries so they point to wish.exe et al.)
> 
> Hope this might help anyone who is having similar problems.  I thought
> there wasn't much changed between GS 1.3.8 and 1.4.0, but it looks like
> something might have been accidentally disturbed...
> 
> Chris
> 
> 
> 


-- 
Bishop Squarepeg Roundhole, BSR
DICK c1d4-2 s:(*) a1973 Comp3d6+1$>? P(robot_sex_slavery) E#=$ F* R?
tv1d2+1 b1d2-1 e! h+ r% y-> !OM !DC http://www.catseye.mb.ca/gwadfc/



More information about the erlang-questions mailing list