starting erlang on remote node

Garry Hodgson <>
Thu Apr 4 21:28:59 CEST 2002


i'm writing some oam scripts to enable users to remotely start up
erlang on various nodes in our linux clusters.  i'm attempting to use
ssh for this, and getting some errors i don't understand.  in
particular,
when i run:

    ssh node0 erl -setcookie cookie -name node -pa $FATHOM/lib -run
master checkin

i get:

   Eshell V5.0.1  (abort with ^G)
   ()1>
   =ERROR REPORT==== 4-Apr-2002::14:09:48 ===
   ** System running to use fully qualified hostnames **
   ** Hostname kestrel is illegal **
   ()1>

and no response to anything i type at this command prompt. the
master:checkin()
from the "-run" arg does not appear to get run.  hitting ^C gets me:

   Killed by signal 2.

the "Hostname kestrel is illegal" error is odd, since i'm running this
command from
a machine named "master", although i did ssh there from kestrel
originally.

if i run the above command with "-node " i get
the same result.
if i run the above command, minus the "ssh node0" on node0, it works
fine.

any ideas?

thanks

-- 
Garry Hodgson                   Let my inspiration flow
Senior Hacker                      in token rhyme suggesting rhythm
Software Innovation Services    that will not forsake me
AT&T Labs                          'til my tale is told and done.




More information about the erlang-questions mailing list