stdup() patch for R7B.

Geoff Wong <>
Sun Oct 1 08:27:24 CEST 2000


> 
> On Sun, Oct 01, 2000 at 03:34:53PM +1100, Geoff Wong wrote:
>  
> > HAVE_STRDUP isn't properly defined by the configure process (and
> > isn't defined in header files on Redhat 6.x boxes).  Anyway - this
> > causes erl_connect (and associated libs) to fail to build.
>  
> > A patch follows.
> 
> <snip>
> 
> I seem to be having this same problem.  I tried this patch, however,
> and it wouldn't work.  I even tried applying it by hand, its being
> small enough.
> 
> Anyhow, when I build I get this:
> 
> make[4]: Entering directory `/opt/erlang.build/otp_src_R7B-0/lib/erl_interface/src'
> gcc -g -O2 -I/opt/erlang.build/otp_src_R7B-0/erts/autoconf/i686-pc-linux-gnu  -fPIC -Wall -O2 -DDEBUG_DIST -I. -DHAVE_CONFIG_H    -DUSE_DNS -DEPMD_PORT=4369 -c erl_connect.c -o /opt/erlang.build/otp_src_R7B-0/lib/erl_interface/obj/i686-pc-linux-gnu/erl_connect.o 
> erl_connect.c:183: parse error before `__extension__'
> erl_connect.c:183: `__len' undeclared here (not in a function)
> erl_connect.c:183: initializer element is not constant
> erl_connect.c:183: parse error before `if'
> erl_connect.c:183: warning: type defaults to `int' in declaration of `__retval'
> erl_connect.c:183: conflicting types for `__retval'
> erl_connect.c:183: previous declaration of `__retval'
> erl_connect.c:183: warning: data definition has no type or storage class
> erl_connect.c:183: parse error before `}'
> 
> 
> Obviously something is going wrong.

Hmm - strange. I'm rebuilding from scratch to re-test my patch.
[ My patch was a reverse patch - but you probably noticed that already ].

As a temporary measure you can edit lib/erl_interface/src/erl_connect.c
and add in a #define HAVE_STRDUP 1 manually (about line 30).

Geoff




More information about the erlang-questions mailing list