stdup() patch for R7B.

Jeffrey Straszhiem <>
Sun Oct 1 07:50:59 CEST 2000

On Sun, Oct 01, 2000 at 03:34:53PM +1100, Geoff Wong wrote:
> HAVE_STRDUP isn't properly defined by the configure process (and
> isn't defined in header files on Redhat 6.x boxes).  Anyway - this
> causes erl_connect (and associated libs) to fail to build.
> A patch follows.


I seem to be having this same problem.  I tried this patch, however,
and it wouldn't work.  I even tried applying it by hand, its being
small enough.

Anyhow, when I build I get this:

make[4]: Entering directory `/opt/'
gcc -g -O2 -I/opt/  -fPIC -Wall -O2 -DDEBUG_DIST -I. -DHAVE_CONFIG_H    -DUSE_DNS -DEPMD_PORT=4369 -c erl_connect.c -o /opt/ 
erl_connect.c:183: parse error before `__extension__'
erl_connect.c:183: `__len' undeclared here (not in a function)
erl_connect.c:183: initializer element is not constant
erl_connect.c:183: parse error before `if'
erl_connect.c:183: warning: type defaults to `int' in declaration of `__retval'
erl_connect.c:183: conflicting types for `__retval'
erl_connect.c:183: previous declaration of `__retval'
erl_connect.c:183: warning: data definition has no type or storage class
erl_connect.c:183: parse error before `}'

Obviously something is going wrong.

-- Jeffrey Straszheim              |  A sufficiently advanced
-- Systems Engineer, Programmer    |  regular expression is
--  |  indistinguishable from
-- stimuli AT shadow DOT net       |  magic

More information about the erlang-questions mailing list