[erlang-bugs] R16A : 2 issues in WX driver compilation

Patrik Nyblom <>
Mon Feb 25 11:11:06 CET 2013


Hi!
On 02/23/2013 10:01 AM, PAILLEAU Eric wrote:
> Le 22/02/2013 16:48, Patrik Nyblom a écrit :
>> I suppose you could try to just edit erts/<your platorm>/config.h after
>> you've run configure and remove #define HAVE_FALLOCATE 1, or in some
>> other way disable fallocate. Configure should detect that it does not
>> work, but the configure test does not do its job in this case. The
>> Erlang system does not depend on fallocate, it just tries to use it if
>> it exists and works.
> Hello Patrick,
>
> That do the trick. Thanks.
Great!
> I already tried to play with config.h but
> by setting
> #define HAVE_FALLOCATE 0
> instead of removing the line !
>
> I certainly crossed my eyes between
> #if
> and
> #if defined !
>
> Note that HAVE_SOMETHING directives can be considered requiring boolean
> values  0/1 ... confusing.
>
> Thanks for the help,
> meanwhile the configure still not detect that the libc does not
> allow fallocate64 and wrongly define HAVE_FALLOCATE ...
> OTP team will certainly think it is not very important
> as far old libc will vanish one day ...
Could you try the attached patch and see if it correctly detects your 
broken fallocate? After applying the patch, you need to cd to the 
patched source dir root and:
$ export ERL_TOP=`pwd`
$ ./otp_build autoconf

Then rerun configure and see what ends up in config.h. Hopefully 
HAVE_FALLOCATE should not be defined.
>
> Regards
> _______________________________________________
> erlang-bugs mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-bugs
Cheers,
/Patrik
-------------- next part --------------
A non-text attachment was scrubbed...
Name: fallocate_config.diff
Type: text/x-patch
Size: 1063 bytes
Desc: not available
URL: <http://erlang.org/pipermail/erlang-bugs/attachments/20130225/bb18c76f/attachment.bin>


More information about the erlang-bugs mailing list