[erlang-bugs] Unclean OTP build directory renders unusable httpc

René Kijewski <>
Mon Jan 2 23:35:39 CET 2012


Hello,

today upgraded to R15B (a67091debf20c972dd7ce1a8379fee6673fbe571).
Before that httpc worked as expected, i.e. httpc:request("http://example.com/") returned some content.

To upgrade I used the following commands:
$ git fetch
$ git checkout OTP_R15B
$ ./otp_build setup -a --prefix=... --enable-threads --enable-smp-support \
$     --enable-kernel-poll --disable-sctp --enable-hipe
$ make install
in a git directory I previously compiled R14B04 and later R15A in.

After upgrading I ran httpc:request("http://example.com/") which did not return.
Even with the timeout option set to 1 the command just hang.

With enabling httpc's trace, I got the attached information.
I guess the important information is:
(<0.41.0>) call httpc_manager:handle_info({'DOWN',#Ref<0.0.0.63>,process,<0.49.0>,{badrecord,request}},
      {state,[],httpc_manager__handler_db,
       {cookie_db,undefined,16402},
       httpc_manager__session_db,httpc_manager,
       {options,{undefined,[]},
                0,2,5,120000,2,disabled,trace,inet,default,default,[]}})

With a full build after cleaning the directory with
$ git clean -xfd
the problem is gone.

Nevertheless I think there is something wrong with some Makefile.

Best regards and a happy new year,
René

-- 
René Kijewski
Freie Universität Berlin                     ASCII ribbon campaign   _
Veterinärmedizinische Bibliothek               against HTML e-mail  ( )
Oertzenweg 19b, 14163 Berlin       against proprietary attachments   X
Tel.: 030 838 62652                            www.asciiribbon.org  / \
-------------- next part --------------
A non-text attachment was scrubbed...
Name: trace.log
Type: text/x-log
Size: 19418 bytes
Desc: not available
URL: <http://erlang.org/pipermail/erlang-bugs/attachments/20120102/a2653eef/attachment-0002.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://erlang.org/pipermail/erlang-bugs/attachments/20120102/a2653eef/attachment-0003.bin>


More information about the erlang-bugs mailing list