[erlang-questions] trying to compile erlang 19.0 on two solaris-on-sparc

HP Wei hpwei01@REDACTED
Sat Mar 9 01:24:42 CET 2019

I am seeking advice on how to solve an issue.

I try to  build erlang from otp_src_19.0 on two solaris on sparc machines.

They both have SunOS 5.11 (11.3)  sun4u sparc
They both have gcc build by Sun’s cc using Sun’s ld and as.
[ I would think that these two machines are exactly the same.]


On the first machine, the building went OK.
NOTE:  configure —prefix=/a/path 

ON the other one, the ‘make’ process went into lib/hipe/misc,  and then
  ERLC ../ebin/hipe_consttab.beam
Failed to create main carrier for binary_alloc

 —> the building failed.


Since the erl run successfully on the first machine,

I copied it to the 2nd machine and tried to run it (erl).
But it failed with the same error message:
Failed to create main carrier for binary_alloc

Anyone has any idea on how I can find the problem?
Something in the system on the 2nd machine must have been set up 


PS:  I first tried to compile version 21.0 But that process failed on both 
       machines with apparently different issues. I was surprised that I got 
       version 19.0 compiled on one machine.

More information about the erlang-questions mailing list