[erlang-questions] origin of handle_info/2

Xavier Noria fxn@REDACTED
Fri Mar 17 12:59:26 CET 2017

On Fri, Mar 17, 2017 at 12:36 PM, Per Hedeland <per@REDACTED> wrote:

Well, some of the original authors were (are) native English speakers:-)
> - but in any case, what's wrong with "info"? Some process, or the VM,
> sent us a message - seems like a reasonable assumption that there is
> some relevant information in it, but that's pretty much the only
> assumption that can be made.

But that is what _any_ function does, right? You get a message, that
contains some data. You could have called the callback "do_stuff" for that

Maybe the OP has a term in mind, that would be better at conveying the
> meaning "any other stuff that someone sends us"?

Yes, I would expect a name more in the line of:

    handle_timeout (split interface for the timeout use-case)

Something that resonates closer to "this is called for any other message
than a call or cast".

Hey, not bikeshedding the callback name at all uh? but was wondering if it
could have had a historic path from a narrower use-case that then widened
with time. Or maybe some rationale for the name that I could be missing.

If there is no such historic background... that is fine, curiosity solved
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20170317/add76c54/attachment.htm>

More information about the erlang-questions mailing list