[erlang-questions] Windows 64bit erlang install actually 32bit?

Eric Cotter ecotter@REDACTED
Thu Sep 4 04:45:42 CEST 2014


I am using RabbitMQ on a Windows 64bit OS.
I installed the 64 bit most recent windows distro.

I ran the erlang console and verified that it is 64 bit.

I installed rabbitmq, which is written in erlang and the installed components are a bunch of beam files.  When I run the server and execute the rabbitmqctl eval erlang:system-info(system-architecture).  I get win32.

I'm facing a problem in my dev environment where erlang is crashing at just 2gb of ram.  I have the crash dump files.  This Windows VM has 25gb ram and 8 cores.  I am running at 30 to 50% CPU utilization when erlang crashes.

I have verified all previous erlang versions have been removed and the registry prior to install.

Any thoughts other then the obvious to install on Linux and I will be.  I have an urgent need to be able to run rabbitmq in a larger memory constraint.

Rabbitmq management UI tells me the erlang instance is 64 bit, however it acts like its 32bit and the architecture tells me so.

What can I do to run RabbitMQ in 64 bit.

Thank you very much!

Eric Cotter
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20140903/fbc5b9eb/attachment.htm>

More information about the erlang-questions mailing list