[erlang-questions] Cluster Functional test using Slave Nodes

marcos quesada marcos.quesadas@REDACTED
Wed Aug 20 20:49:06 CEST 2014

Thanks Ignas! I've tried what you suggest, but unfortunately the result
still the same:

- executing eunit:test('cluster_test') from a started node results in
- executed cluster_test from the test suite:

module 'cluster_test'
  cluster_test: cluster_formation_suite_test_...*timed out*

 What is driving me nuts is the reason about this different behavior, from
start manually the node and execute the test, and in the other hand eunit
test execution environment. Both execution ways are using the same vm.args
and sys.config.

2014-08-20 18:53 GMT+02:00 Ignas Vyšniauskas <baliulia@REDACTED>:

> Hi Marcos,
> I see you dug up an ancient email I wrote. Spawning slave nodes is
> notoriously horrible and unfortunately I already forgot how I fixed the
> issue in question.
> A shot in the dark: have you tried adding something like this:
>     net_kernel:start(['eunit_test_node@REDACTED', longnames])
> before performing `slave:start(..)`? I remember that occasionally the
> issue was that `net_kernel` was not running. Also make sure you have `epmd`
> running in the OS.
> --
> Ignas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20140820/a9dd513a/attachment.htm>

More information about the erlang-questions mailing list