[erlang-questions] Question about basic use of diameter

QDev watson.timothy@REDACTED
Fri Sep 13 11:46:29 CEST 2013

Hi - I'm a bit stuck using the diameter application. Do the Origin-Host and Origin-Realm have to reflect the real host and domain name(s) of the machine(s) in question? After attempts to write and test a basic relay kept failing, I tried using the server.erl and client.erl from the diameter application's ./examples/code directory and things don't seem to be working properly:

Erlang R16B01 (erts-5.10.2) [source] [smp:4:4] [async-threads:10] [hipe] [kernel-poll:false]

Eshell V5.10.2  (abort with ^G)
1> diameter:start().
2> server:start().
3> client:start().
4> client:connect().
** exception error: undefined function client:connect/0
5> client:connect(tcp).
6> client:call().

I get the same problem if I run the client in a separate shell, but the diameter service *is* up an running:

$ netstat -a | grep diameter
tcp4       0      0  localhost.diameter     *.*                    LISTEN 

Whilst testing my own code, instead of {error, no_connection} I get {error,no_service}} back from `diameter:call(?NAME, ?APP_ALIAS, Req, [])' - can anyone suggest what I might be missing here? The tutorial at http://vas.io/blog/2012/05/13/erlang-real-time-server-part-1-diameter-server/ doesn't work for me either - perhaps there is some environment configuration I'm missing?


More information about the erlang-questions mailing list