[erlang-questions] Erlang4android issue on Nexus

Paul Barry paul.james.barry@REDACTED
Thu Mar 28 17:50:23 CET 2013

Hi Erik.

Thanks for your reply.

When I try to run the Erlang shell from the sl4a menu, I get the same
error: Erlang/OTP exited.

I downloaded a file manager to take a look around the filesystem.... The
com.ernovation.erlangforandroid folder does not live in /data/data/, but in
/storage/emulated/11/, and it contains only a single file: the ZIP of the
Erlang download. This is in spite of the installer telling me that the
downloaded file was extracted.  When I manually unzip it, it makes no
difference... I get the same error message.  Also I can't manually run
"erl" as the exec-bit is not set. :-(

Not sure what to try next, but I really don't want to root this thing (my
kids would kill me for wiping their data).

Any suggestions?

Paul Barry
Lecturer, IT Carlow, Ireland
paul.barry@REDACTED - http://paulbarry.itcarlow.ie
On 24 Mar 2013 18:56, "Erik Reitsma" <erlang@REDACTED> wrote:

>  Hi Paul,
> E4A does not require you to root the device. I use it on a non-rooted
> device myself, but not on a Nexus.
> Have you tried starting an interactive Erlang shell from SL4A? E4A is not
> intended to be started from outside SL4A, however, you can start E4A from
> the shell:
> /data/data/com.ernovation.erlangforandroid/files/erlang/bin/erl
> If you start E4A like that, you cannot use the SL4A APIs.
> *Erik.
> On 03/23/2013 02:46 PM, Paul Barry wrote:
> Thanks, John. I recall reading somewhere that E4A doesn't require me to
> root the device.... But, your email has given me hope as well as a few
> pointers to explore.
> Paul.
> On Mar 23, 2013 1:09 PM, "John Kemp" <john@REDACTED> wrote:
>> Hi Paul,
>> I am running Erlang4Android on a Nexus 7, and it works fine. I followed
>> exactly the instructions for installing on the device. Are you running E4A
>> from a BusyBox or over ADB shell? Have you 'rooted' the Nexus 7? E4A
>> doesn't require that AFAIK, but it might make a difference (BusyBox install
>> did require it).
>> JohnK
>> On Mar 23, 2013, at 4:06 AM, Paul Barry wrote:
>> > Hi all.
>> >
>> > I've been playing with one of the new Nexus 7" tablets and I have sl4a
>> installed and running fine (with Python). However, when I install the
>> Erlang4android stuff from code.google.com, I get an "exited" console
>> message whenever I try to run anything (e.g., client.erl from the example).
>> >
>> > I can see from other messages on this list that others have got this
>> working on other devices... But has anybody tried it on a Nexus, and if you
>> did, how did you get on?
>> >
>> > Thanks,
>> >
>> > Paul.
>> >
>> > _______________________________________________
>> > erlang-questions mailing list
>> > erlang-questions@REDACTED
>> > http://erlang.org/mailman/listinfo/erlang-questions
> _______________________________________________
> erlang-questions mailing listerlang-questions@REDACTED://erlang.org/mailman/listinfo/erlang-questions
> _______________________________________________
> erlang-questions mailing list
> erlang-questions@REDACTED
> http://erlang.org/mailman/listinfo/erlang-questions
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20130328/748ddaaf/attachment.htm>

More information about the erlang-questions mailing list