[erlang-questions] OpenCL binding test failure

Thu Jun 20 13:59:36 CEST 2013


I'm having trouble with the OpenCL bindings by TonyRog (https://github.com/tonyrog/cl).
Machine is a Mac Mini running OS X 10.8.4, with Erlang R16B01 (tried with both 64-bit and 32-bit builds).

$ erl -pa cl/ebin
Erlang R16B01 (erts-5.10.2) [source] [64-bit] [smp:8:8] [async-threads:10] [hipe] [kernel-poll:false]

Eshell V5.10.2  (abort with ^G)
1> cl_basic:test().
PlatformInfo: [{profile,"FULL_PROFILE"},
               {version,"OpenCL 1.2 (Apr 25 2013 18:32:06)"},
               {extensions,"cl_APPLE_SetMemObjectDestructor cl_APPLE_ContextLoggingFunctions cl_APPLE_clut cl_APPLE_query_kernel_names cl_APPLE_gl_sharing cl_khr_gl_event"}]
Device: {device_t,429392760,<<>>}
DeviceInfo: [{type,[cpu]},

Sampler2Info: [{reference_count,1},
Program: {program_t,429647808,<<>>}
Trace/BPT trap: 5

I also tried the fix described elsewhere to add "-framework Foundation" to 
 LIBCARBON in erts/configure.in when building Erlang, but same result. 
The failure also occurs with the binary Erlang builds.

Would appreciate any assistance.

More information about the erlang-questions mailing list