[erlang-questions] OTP R16B01 has been released

Thomas Lindgren thomasl_erlang@REDACTED
Thu Jun 20 07:07:55 CEST 2013

Sounds great. Unless there are good reasons to keep the current behavior (anyone?), how about just naming your patch start/1?

The current behavior, should one need it, might be renamed to start_only/1. Maybe add a boolean function to check if an application has been started. Anything else?


> From: Geoff Cant <nem@REDACTED>
>Interestingly, with correct OTP .app files, 'application' has enough information to start my app and all its dependencies. Currently 'application' is a bit of a jerk - it tells me the exact app that it could have started for me, that is a missing start dependency for the app I am trying to start.
>These lines may make development a little easier for you right now, and either I, or someone soon to be on my famed Holiday Card List, will hopefully fix this wart before R16B02.
>Anyone have suggestions for a function name for this feature? application:recursive_start/2? application:start_recursively/2? application:run/2?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20130619/6747d4a0/attachment.htm>

More information about the erlang-questions mailing list