[erlang-questions] -detached works until I exit shell

Wes James comptekki@REDACTED
Fri Nov 9 18:19:35 CET 2012

I toyed with the yaws startup script and now it works to start my app.  The
key might be using the run_erl instead of using detached.


On Wed, Oct 31, 2012 at 10:31 AM, Wes James <comptekki@REDACTED> wrote:

> I have an erlang app I run with -detached and it works fine until I exit
> the shell I ran it from.
> I'm on xubuntu, and run
> erl -name node@REDACTED -pa /my/ebin -s module -setcookie somecookie -detached
> I first used startup scripts in xubuntu but I couldn't get to the node.
> I then tried running emacs in daemon mode, run the app and then
> ctrl-x,ctrl-c to get out of emacs, but leave it running, but when I do that
> the app stops responding.
> Anyone know why?
> Thanks,
> Wes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20121109/8057974e/attachment.htm>

More information about the erlang-questions mailing list