[erlang-questions] Regd: Erlang

preeti sp preetisp_83@REDACTED
Wed Jan 11 03:56:55 CET 2012


Refer my answers below:

- what ubuntu version are you installing onto :- 11.10

- what command(s) you are running to build/install : I am using below commands you stated: make, configure, make install. I am not passing any options.

- what output and/or error messages are you getting: 
I am getting a bunch of errors stating - all erlang dependencies are missing - like odbc etc...

I tried installing as Magnus said using below command as well:
dpkg -i
But, I am getting below error now with that approach:

(Reading database ... 59952
files and directories currently installed.)

Preparing to replace esl-erlang 1:15.b (using esl-erlang_15.b-1_amd64.deb) ...

Unpacking replacement esl-erlang ...

dpkg: dependency problems prevent configuration of esl-erlang:

esl-erlang depends on default-jre-headless | java2-runtime-headless |
java1-runtime-headless | java2-runtime | java1-runtime; however:

Package default-jre-headless is not installed.

Package java2-runtime-headless is not installed.

Package java1-runtime-headless is not installed.

Package java2-runtime is not installed.

Package java1-runtime is not installed.

esl-erlang depends on libwxbase2.8-0; however:

Package libwxbase2.8-0 is not installed.

esl-erlang depends on libwxgtk2.8-0; however:

Package libwxgtk2.8-0 is not installed.

dpkg: error processing esl-erlang (--install):

dependency problems - leaving unconfigured

Errors were encountered while processing:

--- On Sat, 1/7/12, Tim Watson <watson.timothy@REDACTED> wrote:

From: Tim Watson <watson.timothy@REDACTED>
Subject: Re: [erlang-questions] Regd: Erlang
To: "preeti sp" <preetisp_83@REDACTED>
Cc: erlang-questions@REDACTED
Date: Saturday, January 7, 2012, 1:54 AM

Hi Preeti,
I quite understand. Magnus has replied with a link to some pre-packaged distributions - I'd completely forgotten about those - and they're probably the best way to go.

Installing Erlang on Ubuntu should just be a matter of running the apt/aptitude commands. Compiling from source involves grabbing the download from the erlang.org website and running `./configure && make && make install` with some --options passed to configure. If you still want to build/install using apt or from sources, please reply with the following information so we can help:

- what ubuntu version are you installing onto - what command(s) you are running to build/install- what output and/or error messages are you getting
With these details, I'm sure we'll be able to help!

On 7 January 2012 03:43, preeti sp <preetisp_83@REDACTED> wrote:

Hi Tim,

I am not an erlang person. I am mainly working with RabbitMQ. I am not clear with below mail details. Could you please let me know exact details on how do I install erlang successfully on ubuntu (Right now, it is not getting installed properly and stating that ncurses not found is the reason for erlang's improper installation)


--- On Fri, 1/6/12, Tim Watson <watson.timothy@REDACTED> wrote:

From: Tim Watson <watson.timothy@REDACTED>
Subject: Re: [erlang-questions] Regd: Erlang
To: "preeti sp" <preetisp_83@REDACTED>

Cc: erlang-questions@REDACTED
Date: Friday, January 6, 2012, 1:37 PM

If you need to build curses by hand then do so - just
 run ./configure --help to see what flags are required to produce a 64 bit binary. Then just point the Erlang configure script at it. Otherwise, you could just do --without-curses or whatever when building Erlang, but personally I'd want (n)curses enabled.

Personally I'd suggest you build it by hand from sources, or use kerl and pass KERL_CONFIGURE_OPTS based on the install documentation if you prefer.  

On 6 January 2012 18:02, preeti sp <preetisp_83@REDACTED> wrote:

I actually followed the exact steps illustrated in the link you shared below (GNU/LINUX) on ubuntu.

But, when I executed below command, I got a message saying corresponding libraries not found to install. Since those libraries did not install well, erlang installation also showed an error at the end saying - curses library not found. So, rabbitmq installation failed!

What i need is proper detailed commands to install below libraries on ubuntu x86-64 machine configuration!

sudo apt-get install build-essential libncurses5-dev openssl libssl-dev

--- On Fri, 1/6/12, Tim Watson <watson.timothy@REDACTED> wrote:

From: Tim Watson <watson.timothy@REDACTED>
Subject: Re:
 [erlang-questions] Regd: Erlang
To: "preeti sp" <preetisp_83@REDACTED>
Cc: erlang-questions@REDACTED

Date: Friday, January 6, 2012, 4:25 AM

And reading http://wiki.basho.com/Installing-Erlang.html might help too.

On 6 January 2012 12:24, Tim Watson <watson.timothy@REDACTED> wrote:

Have you tried installing from sources? It sounds like perhaps the ./configure script needs to know --with-curses (or whatever the actual switch is to point to the ncurses you've installed) and/or the architecture you're installing for one isn't compatible with the other.

If you want detailed assistance, please provide a bit more information about *how* you're trying to install and what is going wrong (like error messages etc).
Also, what version of Ubuntu are you using and do you have the build-essential packages installed?

On 6 January 2012 11:34, preeti sp <preetisp_83@REDACTED> wrote:


I am struggling since many days to install RabbitMQ on Ubuntu Machine (X86-64)

Now, Erlang is a pre-requisite for Installing RabbitMQ

When I try to Install Erlang, I get an error message saying - Ncurses library is not installed.

I tried installing ncurses library in multiple ways using sudo apt-get commands. It does not happen and so I am not able to install erlang successfully

Can anyone provide me a list of detailed steps to be able to install erlang version 14 on an ubuntu machine?



erlang-questions mailing list



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20120110/a8e28da6/attachment.htm>

More information about the erlang-questions mailing list