[erlang-questions] Help running Erlang as a Service on XP Embedded

Daniel Lewis DanielLewis@REDACTED
Wed Dec 12 23:36:31 CET 2012

Hi Robby and Dave

I tried Dave's suggestions - I notice no difference when I set the cookie to "yumyumyum" in the batch files  (I still get the "nodedown" message for rabbit@REDACTED)

The things Robby wanted to verify do not work.  I cannot use it normally, when I try to connect I get a "Could not connect to Broker" message.

http://localhost:55672/   returns a message that "Internet Explorer cannot display the webpage"

Also, I do not see any log files with today's date on them... they all have old dates, and are probably from when I was running this in the foreground

From: Robert Raschke [mailto:rtrlists@REDACTED]
Sent: Wednesday, December 12, 2012 1:56 PM
To: Daniel Lewis
Cc: erlang-questions@REDACTED
Subject: Re: [erlang-questions] Help running Erlang as a Service on XP Embedded

Hi Daniel,

a few things to verify:

Is RabbitMQ actually up and running? That is, can you use it normally, connect, create/use exchanges, queues etc.? Is the REST API running? Or the managment plugin?

If yes, then the next step would be to fix the cookie in the bat files. For that you'll need to unregister the service again, then edit the register service bat to include the -setcookie argument, and as Dave mentions it might be worth ensuring that your local name is set to include the host part explicitly as well here. Also add the -setcookie into the rabbitmqctl.bat.

If your service is in fact not usable at all, then having a closer look at the log files is in order.

Actually, looking at the log files is a good idea in any case.

On Wed, Dec 12, 2012 at 7:52 PM, Dave Cottlehuber <dch@REDACTED<mailto:dch@REDACTED>> wrote:
On 12 December 2012 20:41, Daniel Lewis <DanielLewis@REDACTED<mailto:DanielLewis@REDACTED>> wrote:
> Hi Robby,
> Thanks for the suggestion.
> I searched for files called ".erlang.cookie" and I only see two of them -
> should there be more?   I checked and these two files are identical,
> including contents, size, and date.
Likely if you are running this as a service the home directory will
not be where you are expecting it to be. This was covered in
erlang-question archives in the last few months, I can't recall the
specifics off the top of my head.

Try adding `-setcookie yumyumyum` to the batch file as suggested earlier.

You might be able to try setting this up with erlsrv.exe and adding
`-debugtype console` to the parameters. You can then interact with the
hidden service console (winsta0) directly. I don't know if this works
on embedded XP but its a good way to try.

I'm not sure on the rabbit parameters but your shortname probably
should be "erl  -sname rabbitmqctl@REDACTED" if you want to set the
@…. section directly.

erlang-questions mailing list

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20121212/17fa9670/attachment.htm>

More information about the erlang-questions mailing list