[erlang-questions] Running rebar generated release failing with "Kernel pid terminated"

Vineet Naik naikvin@REDACTED
Wed Dec 12 16:31:48 CET 2012


I am trying to package my app using rebar. `rebar generate` command runs
without any
problem (no errors at least). But when I try to start the console by
running the script generated
by rebar in bin directory, it fails with "Kernel pid terminated"

A huge crash_dump is also created but I am not able to gather any info from

I checked the erlang docs[1], I found this paragraph about the error

"Kernel pid terminated (Who) (Exit-reason)" - The kernel supervisor has
> detected a failure, usually that the application_controller has shut down
> (Who = application_controller, Why = shutdown). The application controller
> may have shut down for a number of reasons, the most usual being that the
> node name of the distributed Erlang node is already in use. A complete
> supervisor tree "crash" (i.e., the top supervisors have exited) will give
> about the same result. This message comes from the Erlang code and not from
> the virtual machine itself. It is always due to some kind of failure in an
> application, either within OTP or a "user-written" one. Looking at the
> error log for your application is probably the first step to take.

If I run `console_clean` command, then the console start in the correct
node. Does
this rule out the "Node is already in use" case above?

I also tried running the code from an erlang shell with the ebin dir paths
of all required
libs added manually to sys path and it works perfectly.

How can I go about debugging this?

[1] http://www.erlang.org/doc/apps/erts/crash_dump.html#id71973

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20121212/ea34b608/attachment.htm>

More information about the erlang-questions mailing list