[erlang-questions] Erlang on ARM9?

Gustav Simonsson gustav.simonsson@REDACTED
Mon Oct 3 14:46:30 CEST 2011

Unless you are compiling on the ARM platform for the that platform, 
your --build is most likely wrong, as Matt pointed out.

You have erl_xcomp_build=arm-unknown-linux-gnu in your xcomp file,
try setting this value to 'guess' and see if that works, that will
run erts/autoconf/config.guess to grab the (most likely) correct
value for --build. It is also the default value for Erlang xcomp
conf files.

Gustav Simonsson

----- Ursprungligt meddelande -----
Från: "Matthias Lang" <matthias@REDACTED>
Till: "Guy Wiener" <wiener.guy@REDACTED>
Kopia: "Erlang Questions" <erlang-questions@REDACTED>
Skickat: måndag, 3 okt 2011 14:33:03
Ämne: Re: [erlang-questions] Erlang on ARM9?


It's pretty odd that in your case --build is an ARM. Are you typing those
commands on an ARM system or on an x86?

Or: I don't know what you're doing but it looks wrong.

As a quick way to give you more information, I've put a log which shows
exactly what I do to build my ARM version in a clean erlang source tree:


The only non-comment difference between my ARM xconf file and the MIPS
one supplied with R14B03 is:




On Monday, October 03, Guy Wiener wrote:

> I've tried running the otp_build script with an xcomp configuration file,
> but encountered the following problem: the configuration script tries to run
> the file generated by the cross-compiler and fails, although the --host flag
> is given.
> In details:
> I run "./otp_build configure
> --xcomp-conf=xcomp/erl-xcomp-arm-linux-gnu.conf"
> The bootstrap build system is configured properly.  When configuring the
> cross host system, it uses the following command:
> ./configure --disable-dynamic-ssl-lib --build=arm-unknown-linux-gnu
> --host=arm-unknown-linux-gnu
> CC=/opt/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-gcc
> CFLAGS=-mcpu=arm926ej-s
> CXX=/opt/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-g++
> LD=/opt/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-ld --disable-hipe
> --cache-file=/dev/null
> But then it causes the following error:
> checking whether the C compiler works... configure: error: cannot run C
> compiled programs.
> If you meant to cross compile, use `--host'.
> But the configuration command is given a proper --host option!
> I attach the cross compilation configuration file.  Any advice is warmly
> welcomed.
> Thanks,
>   Guy Wiener.
erlang-questions mailing list

More information about the erlang-questions mailing list