[erlang-questions] mnesia lookup weirdness

Chandru chandrashekhar.mullaparthi@REDACTED
Thu Jul 14 08:37:43 CEST 2011

For the record, I've found out what was causing this.

A process was regularly executing ets:safe_fixtable(true) on this table, and
not finishing off with ets:safe_fixtable(false).

This meant that the behaviour of mnesia:dirty_first was affected, and was
also causing increased memory consumption.

Thanks to Håkan and Sverker for helping me find the root cause.


On 1 July 2011 14:44, Chandru <chandrashekhar.mullaparthi@REDACTED> wrote:

> Hi,
> One of my production nodes running R12B-5 is exhibiting some strange
> behaviour.
> mnesia:dirty_read(gtp_tid, mnesia:dirty_first(gtp_tid)).
> gives me an empty list. The table has 39K entries. How do I find out what
> is happening? I tried using ets operations directly and get the same result
> (which is what mnesia is doing behind the scenes anyway). I get the same
> empty result using a transaction to read. Any clues?
> 96> ets:info(gtp_tid).
> [{memory,213857900},
>  {owner,<0.741.0>},
>  {name,gtp_tid},
>  {size,39088},
>  {node,node@REDACTED},
>  {named_table,true},
>  {type,set},
>  {keypos,2},
>  {protection,public}]
> The same operation works ok on other tables.
> cheers
> Chandru
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20110714/6b81930f/attachment.htm>

More information about the erlang-questions mailing list