[erlang-questions] dialyzer crash

Roman Shestakov romanshestakov@REDACTED
Sat Dec 10 23:45:26 CET 2011


I am having a problem with running dialyzer, it started crashing with  the following err.:

bash-3.2$ dialyzer -Wno_return --plt ~/.ec_master_dialyzer_plt ebin
  Checking whether the PLT /Users/romanshestakov/.ec_master_dialyzer_plt is up-to-date... yes
  Compiling some key modules to native code... done in 1m26.60s
  Proceeding with analysis...{"init terminating in do_boot",{function_clause,[{dialyzer,message_to_string,["Unexpected multiple opaque types"]},{dialyzer,format_warning,2},{dialyzer_cl,'-print_warnings/1-lc$^0/1-0-',2},{dialyzer_cl,'-print_warnings/1-lc$^0/1-0-',2},{dialyzer_cl,print_warnings,1},{dialyzer_cl,return_value,2},{dialyzer_cl,do_analysis,4},{dialyzer,'-cl/1-fun-0-',1}]}}

Crash dump was written to: erl_crash.dump
init terminating in do_boot ()

I am using Erlang R14B04 (erts-5.8.5)

what would be the best way to isolate the offending code?
I tried to run dialyzer on each beam file in my ebin separately, everything works, the crash seems to be only happening when I run against the entire ebin folder.

Regards, Roman
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20111210/07629ddb/attachment.htm>

More information about the erlang-questions mailing list