I have trouble with R14B/wx/Windows XP

Pascal Chapier pascalchapier@REDACTED
Wed Sep 22 16:11:14 CEST 2010

Hi list,

I have trouble with the R14B release under Windows XP.
It seems that the wx library does not work properly on my PC.

I installed the R14B on my PC, in addition to the R14A which I use by default.

If I launch werl from the erl5.8.1\bin directory, and try to launch an application which use wx, it crashes
without any log or valuable information:

werl session:
Erlang R14B (erts-5.8.1) [smp:2:2] [rq:2] [async-threads:0]

Execution des cmds erlang from "D:\documents and Settings\PChapier\.erlang
"Nom de la machine: "WXFR88952L", cookie nocookie
Eshell V5.8.1  (abort with ^G)
1> debugger:start().

crash message (translated from french):
werl.exe - Application error
The instruction at "0x7C911980" uses the address memory location "0x00000000". The memory cannot be read.

The crash happens as soon as the wx:new() function is called (I made the call directly
from the shell to check it).
I changed the windows path to use the R14B by default: same behaviour.
A very strange thing is that it has worked properly once with debbugger:start(),
and once with wx:new() within more than 20 trials; but as soon as I stopped wx, I got a crash at the next call
to wx:new/0.

I have tried also the toolbar, tv,appmon... and some application without graphic or using gs:
no problem except toolbar->debugger.

It is ok with R14A.

Any idea?




More information about the erlang-questions mailing list