I think I wish I could write case Any of whatever -> _ end.

Eric Newhuis (personal) enewhuis@REDACTED
Fri May 14 21:05:44 CEST 2010


Consider:

X = case Any of
		very_long_pattern_or_whatever ->
			very_long_pattern_or_whatever
	end.


I'd rather abbreviate that like this.

X = case Any of
	very_long_pattern_or_whatever -> _
	end.

It also seems more readable to me than:

X = case Any of
	very_long_pattern_or_whatever=Y -> Y
	end.



More information about the erlang-questions mailing list