build of R13B03 failing on Ubuntu 8.04

Amit Murthy amit.murthy@REDACTED
Wed Jan 27 08:14:53 CET 2010


The configure-make-install cycle is failing in the make phase on my Ubuntu
8.04.1 box. The error I am seeing is

make[3]: Entering directory
erlc -W  +debug_info +warn_exported_vars -o../ebin hipe_sparc_assemble.erl
./hipe_sparc_assemble.erl:none: internal error in core_module;
crash reason: {{case_clause,{{var,380,'Word'},[]}},
make[3]: *** [../ebin/hipe_sparc_assemble.beam] Error 1
make[3]: Leaving directory
make[2]: *** [opt] Error 2
make[2]: Leaving directory
make[1]: *** [opt] Error 2
make[1]: Leaving directory `/home/amitm/Downloads/erlang/otp_src_R13B03/lib'
make: *** [secondary_bootstrap_build] Error 2

FWIW, I tried the following:

If I execute directly the command
./bin/i686-pc-linux-gnu/erlc -W  +debug_info +warn_exported_vars -o../ebin

it compiles but
./bootstrap/bin/erlc -W  +debug_info +warn_exported_vars -o../ebin
gives the same error as above.

In the first case, the erlc command will be using erl from my currently
system installed erlang (version R13A).

Any help will be much appreciated.


More information about the erlang-questions mailing list