[erlang-questions] Erlang/OTP R14B01 has been released

Boris Mühmer boris.muehmer@REDACTED
Wed Dec 8 21:05:07 CET 2010

Am Mittwoch, den 08.12.2010, 15:49 +0100 schrieb Kenneth Lundin:
> Erlang/OTP R14B01 has been released.
> [...]

Great news!

But I ran into some troubles installing it: my final step (using a
script) is to call "sudo make install-docs". But this time it failed
with the following error:


${PATH} \
                make RELEASE_ROOT=/opt/otp-R14B01/lib/erlang
        make[1]: Entering directory
        /home/bsmr/Source/Erlang/System/otp_src_R14B01/lib/erl_docgen/priv/bin/xref_mod_app.escript -topdir /home/bsmr/Source/Erlang/System/otp_src_R14B01 -outfile /home/bsmr/Source/Erlang/System/otp_src_R14B01/make/x86_64-unknown-linux-gnu/mod2app.xml
        /home/bsmr/Source/Erlang/System/otp_src_R14B01/lib/erl_docgen/priv/bin/xref_mod_app.escript:89: can't find include lib "xmerl/include/xmerl.hrl"
        escript: There were compilation errors.
        make[1]: *** [mod2app] Error 127
        make[1]: Leaving directory
        make: *** [install-docs] Error 2

I never saw this before "R14B01".

After some messing around a bit, I changed the shebang of 
from "#!/usr/bin/env escript" to "#!/opt/otp-R14B01/bin/escript" and the
"sudo make install-docs" worked.

It looks like I have to check the man page of sudo again, because it
looks like it ignores some "parts" (like PATH) of my (development)

To check this behaviour, I made a small escript:

        #!/usr/bin/env escript
        main(_Args) ->
                Info = code:lib_dir(xmerl),
                io:format("xmerl lib dir: ~p~n", [Info]).
        % EOF

The output is the following:

        $ ./test.escript 
        xmerl lib dir: "/opt/otp-R14B01/lib/erlang/lib/xmerl-1.2.7"
        $ sudo ./test.escript 
        xmerl lib dir: "/usr/lib/erlang/lib/xmerl-1.2.3"

Well, I am just glad it works now... and about to "man sudo"...

  - boris

More information about the erlang-questions mailing list