[erlang-questions] Erlang crypto_drv in R13B02/03 fails to load on amd64-Solaris2.10

Peter-Henry Mander phmander@REDACTED
Fri Nov 20 23:43:05 CET 2009

Yes, that bug looks awfully similar to mine, and the explanation also
concurs with my fuzzy understanding of what is going on. "Will not
fix" since 2004? Kind of bad, indeed.

I tried -mcmodel=medium, which didn't solve the issue, and
-mcmodel=large which broke *all* of the erl_interface C file

Aside: The "medium/large memory model" is only available with GCC-4
for shared libraries, not GCC-3, and that led me on to another,
different battle to compile GCC version 4. I succeeded thanks to
Gilles Dauphin: http://www.infres.enst.fr/~dauphin/pkgsrcmywork/

The -fPIC flag is used pretty much everywhere I looked, and flew past
very often as I went cross-eyed gazing at the compilation output,
Matrix style.

The -shared and -G flags, I don't recall seeing. I may try looking for
this on Monday.


On Fri, Nov 20, 2009 at 10:25 PM, Wallentin Dahlberg
<wallentin.dahlberg@REDACTED> wrote:
> We haven't had time to investigate this problem yet. (Lots of release stuff
> going on today).
> However, it seems like similar problems exists on opensolaris + AMD64.
> For instance:
> http://bugs.opensolaris.org/bugdatabase/view_bug.do;jsessionid=a68c8de187c30929fb79755edd017?bug_id=5102797
> This would be kind of bad.
> I don't have your build log in front of me so I can't see if this is the
> case but similar problems has been solved with -fPIC and -shared and not -G
> when using gcc on solaris.
> LDFLAGS += -shared
> // Björn-Egil

More information about the erlang-questions mailing list