Unable to start YAWS

Jacek Furmankiewicz jacek99@REDACTED
Thu Jul 2 19:09:31 CEST 2009

We've been developing an OTP app on Ubuntu with embedded YAWS and all is

We tried moving it to our production OS (CentOS 4.7) where I've manually
compiled R12B-5. Unfortunately on this OS we get a startup error like this:

    application: das
    exited: {bad_return,

Is there something missing in my setup? Does anyone know what is the cause
of the check_certs error?

I was guessing it may be SSL-related, so I downloaded openssl and
openssl-devel on CentOS and recompiled Erlang from scratch with them..but
same error persists.

Any suggestions would be welcome...

Cheers, Jacek

P.S. basic sample of our YAWS code (nothing fancy, as you can see):

    GL = [{enable_soap,true}, {tmpdir,"res"},{logdir,"res"},

    SL = [{port,?YAWS_PORT},{servername,"localhost"},{dir_listings,true},
    yaws:start_embedded(".", SL, GL),
    yaws_soap_srv:setup({das_http,handler}, ?WSDL).

More information about the erlang-questions mailing list